Una delle funzioni più utilizzate ed apprezzate di Microsoft Excel è la funzione "SE" che permette di replicare la struttura logica "IF-THEN-ELSE", utile per eseguire calcoli complessi o visualizzare del testo in base al verificarsi di determinate condizioni. Se hai dei dubbi su come si usa la funzione "SE" di Excel, questo articolo ti sarà di grande aiuto dato che spiega qual è la sintassi da usare e contiene alcuni esempi, dai più semplici fino a quelli che utilizzano condizioni multiple annidate. Prosegui nella lettura per poter analizzare formule di esempio, ricevere consigli utili e informazioni su come risolvere i problemi più comuni.

Metodo 1
Metodo 1 di 4:
Sintassi della Funzione SE

  1. 1
    =SE(condizione, se_condizione_è_vera_esegui_questa_azione, altrimenti_esegui_questa_azione). La funzione "SE" esegue un confronto logico indicato nella condizione per stabilire se il risultato è vero o falso.
    • condizione: si tratta della condizione che verrà testata ed è un parametro obbligatorio;
    • se_condizione_è_vera_esegui_questa_azione: si tratta del risultato da visualizzare o dell'azione da compiere nel caso in cui la condizione testata sia vera. Anche questo è un parametro obbligatorio;
    • altrimenti_esegui_questa_azione: si tratta del risultato visualizzato o dell'azione da compiere in caso la condizione testata sia falsa. Questo è un parametro opzionale.
    Pubblicità

Metodo 2
Metodo 2 di 4:
Formule di Esempio

  1. 1
    =SE(B3>C3, "Obiettivo raggiunto", "Obiettivo non raggiunto").
    • In questo esempio la condizione della formula è rappresentata dal confronto B3>C3, che significa "se il valore della cella B3 è maggiore di quello della cella C3 allora...".
    • Se la condizione è vera, quindi il valore della cella B3 è effettivamente maggiore di quello della cella C3, allora il testo Obiettivo raggiunto verrà visualizzato nella cella in cui è stata inserita la formula.
    • Se la condizione è falsa, quindi il valore della cella B3 è minore o uguale a quello della cella C3, allora il testo Obiettivo non raggiunto verrà visualizzato nella cella in cui è stata inserita la formula.
  2. 2
    =SE(B3=C3, "Obiettivo raggiunto").
    • In questo esempio la condizione della funzione "SE" è B3=C3, che va letta in questo modo: "se il valore della cella B3 è uguale a quello della cella C3 allora...".
    • Nel caso i due valori confrontati siano uguali, il testo "Obiettivo raggiunto" verrà visualizzato nella cella in cui è stata inserita la funzione "SE".
    • Se i due valori confrontati non sono uguali, nella cella in cui è stata inserita la formula verrà visualizzato uno zero. Questo avviene perché non è stato specificato cosa fare quando la condizione non del test risulta falsa (l'istruzione "ELSE" della struttura logica "IF-THEN-ELSE" replicata dalla funzione "SE" di Excel).[1]
  3. 3
    =SE(B3*2>C3, C3*400, "Ok").
    • In questo esempio la condizione da testare è B3*2>C3, che significa "Se il valore della cella B3 moltiplicato per 2 è maggiore di quello della cella C3 allora...".
    • Se il valore della cella B3 moltiplicato per 2 è maggiore del valore della cella C3, allora il prodotto di quest'ultimo per 400 verrà visualizzato nella cella in cui è stata inserita la funzione "SE" in oggetto.
    • Se il risultato della moltiplicazione "B3*2" non è maggiore del valore della cella C3, allora il testo "Ok" verrà visualizzato nella cella in cui è stata inserita la formula.
  4. 4
    =SE(B3="Venduto", "1", "")
    • In questo esempio la condizione del test è B3="Venduto", che significa "Se il valore della cella "B3" è uguale alla parola Venduto allora...".
    • Se la cella "B3" contiene la parola "Venduto", il numero "1" verrà visualizzato all'interno della cella in cui è stata inserita la funzione "SE".
    • Se la cella "B3" contiene qualsiasi altro valore all'infuori della parola "Venduto", la condizione risulterà falsa. Dato che il parametro "ELSE" della formula di questo esempio è rappresentato dal testo " ", cioè uno spazio vuoto, la cella in cui è stata inserita la funzione "SE" apparirà vuota.
  5. 5
    =SE(D3="Tassato", F3*0,07, "0").
    • In questo esempio la condizione del test è D3="Tassato", che significa "Se il valore della cella D3 è uguale alla parola Tassato allora...".
    • Se la cella "D3" contiene la parola "Tassato", il risultato della formula sarà pari al prodotto del valore della cella "F3" moltiplicato per 0,07.
    • Se la cella D3 contiene qualsiasi altro valore all'infuori della parola "Tassato", allora il risultato della formula sarà 0.
  6. 6
    Cose da ricordare:
    • La funzione "SE" può dare come risultato due valori: uno nel caso la condizione testata sia vera e l'altro nel caso la condizione sia falsa.
    • La parte della sintassi della funzione "SE" che rappresenta l'istruzione "ELSE" del blocco logico "IF-THEN-ELSE" che ricrea, rappresentata dal valore da visualizzare nel caso la condizione testata risulti falsa, è opzionale. Nel caso questo parametro non venga specificato, se la condizione della funzione "SE" risulta falsa, nella cella verrà visualizzato uno "0". Se hai la necessità che la cella rimanga vuota, dovrai completare la sintassi della funzione "SE" aggiungendo la stringa "" come terzo parametro.
    • Quando si fa riferimento a un testo specifico come condizione o come parametro da visualizzare come risultato, occorre sempre inserirlo nella formula fra virgolette.
    Pubblicità

Metodo 3
Metodo 3 di 4:
Testare Condizioni Multiple

  1. 1
    È possibile annidare fino a 64 formule "SE" in una sola formula. Per esempio ipotizza di voler creare una formula per il calcolo della tassazione dell'acquisto di merci che hanno aliquote diverse. In questo scenario dovrai creare una formula che contenga al suo interno quattro formule "SE" annidate per poter testare 4 condizioni diverse. Assumendo che l'importo dell'acquisto sia memorizzato nella cella G1 e che l'aliquota da applicare per la tassazione sia memorizzata nella cella F1, la formula apparirà come segue:
    • =SE(F1="Aliquota_1", G1*0, SE(F1="Aliquota_2", G1*0,0725, SE(F1="Aliquota_3", G1*0, SE(F1="Aliquota_4", G1*0,065))))
  2. 2
    Annidare numerose formule "SE" può risultare complesso e arduo. Aldilà di formule estremamente lunghe, quando si utilizzano numerose formule "SE" annidate risulta molto difficile e complesso riuscire a modificarle correttamente in base alle necessità senza commettere errori di sintassi. Nell'esempio precedente la formula dovrà essere modificata ogni volta che le aliquote della tassazione variano.
    • In questo scenario, una buona alternativa all'uso della funzione "SE" consiste nell'inserire i valori da testare in una tabella e usare la funzione Cerca.Vert di Excel per cercare all'interno della tabella l'aliquota corretta da applicare al calcolo.
    • Per esempio, inserendo nella colonna A della tabella i nomi delle aliquote e nella colonna B la tassazione da applicare, possiamo usare la funzione "CERCA.VERT" che non comprenderà al suo interno il valore di ogni aliquota, ma solo il riferimento alla cella della tabella in cui lo abbiamo memorizzato. La formula condensata corrispondente alla versione dell'utilizzo di più funzioni "SE" annidate sarà la seguente =G1*CERCA.VERT(F1,A:B,2,TRUE).
    • Nel caso in cui dovessi modificare il valore di un'aliquota dovrai semplicemente modificare la cella corrispondente della tabella e non tutte le formule in cui hai inserito direttamente la percentuale della tassazione da usare per il calcolo.
    Pubblicità

Metodo 4
Metodo 4 di 4:
Risoluzione dei Problemi

  1. 1
    Il risultato della formula è 0. Questo significa che non è stato specificato il parametro della funzione "SE" nel caso in cui la condizione testata sia falsa, ma solo nel caso in cui sia vera.[2]
    • Se non viene specificato il parametro da usare quando la condizione della funzione "SE" è falsa, il risultato , per impostazione predefinita, sarà sempre 0.
  2. 2
    Come risultato si ottiene l'errore #NOME?. Questo significa che nella formula è presente un errore di sintassi. Assicurati di aver inserito i parametri della formula fra parentesi dopo il segno = e che siano separati correttamente da virgole. Inoltre quando i parametri sono caratterizzati da testo occorre racchiuderlo fra virgolette.
    • Per esempio la seguente funzione "SE" dà come risultato l'errore #NOME? perché il testo OK non è stato inserito fra virgolette: =SE(A2>1,OK).
    • La sintassi corretta della formula in oggetto è la seguente =SE(A2>1,"OK").
    Pubblicità

wikiHow Correlati

Sostituire una Virgola con un Punto in ExcelSostituire una Virgola con un Punto in Excel
Calcolare l'Età in ExcelCalcolare l'Età in Excel
Individuare il Codice Product Key di OfficeIndividuare il Codice Product Key di Office
Usare la Numerazione Automatica in ExcelUsare la Numerazione Automatica in Excel
Scoprire le Righe Precedentemente Nascoste in Excel
Creare il Simbolo X Segnato su WordCreare il Simbolo X Segnato su Word
Troncare il Testo in ExcelTroncare il Testo in Excel
Creare un Inventario con ExcelCreare un Inventario con Excel
Trovare Valori Uguali all'Interno di Due Colonne di un Foglio di ExcelTrovare Valori Uguali all'Interno di Due Colonne di un Foglio di Excel
Aggiungere un Segno di Spunta a un Documento di WordAggiungere un Segno di Spunta a un Documento di Word
Inserire un Pulsante di Spunta in WordInserire un Pulsante di Spunta in Word
Aggiungere un Secondo Asse Y in un Grafico di Microsoft ExcelAggiungere un Secondo Asse Y in un Grafico di Microsoft Excel
Confrontare i Dati con ExcelConfrontare i Dati con Excel
Scannerizzare DocumentiScannerizzare Documenti
Pubblicità

Informazioni su questo wikiHow

Lo Staff di wikiHow
Co-redatto da:
Staff di wikiHow - Redazione
Questo articolo è stato scritto in collaborazione con il nostro team di editor e ricercatori esperti che ne hanno approvato accuratezza ed esaustività.

Il Content Management Team di wikiHow controlla con cura il lavoro dello staff di redattori per assicurarsi che ogni articolo incontri i nostri standard di qualità.
Categorie: Office
Questa pagina è stata letta 72 volte.

Hai trovato utile questo articolo?

Pubblicità